Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Markers and ID

 Post Reply Post Reply
Author
Craggs David View Drop Down
New Member
New Member
Avatar

Joined: 25 Jan 2013
Posts: 21
Post Options Post Options   Quote Craggs David Quote  Post ReplyReply Direct Link To This Post Topic: Markers and ID
    Posted: 07 Sep 2019 at 4:57pm
I am adding markers to a map.

Th ID number start at zero and increments. so If I add 12 markers, the id range is 0-11.

If I then clear the markers and add new markers, The ID of the next set starts at 12.

I was assuming that IdMarker in events would match Marker.Id, but this doesn't seem to be the case.

Can you help?

Dave Craggs
 
Back to Top
Craggs David View Drop Down
New Member
New Member
Avatar

Joined: 25 Jan 2013
Posts: 21
Post Options Post Options   Quote Craggs David Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2019 at 5:18pm
I'm trying to locate the Marker in event OnMarkerClick.

But I'm getting a strange situation where markers disappear on being clicked when I access WebGMaps1.Markers in this event.
Back to Top
Craggs David View Drop Down
New Member
New Member
Avatar

Joined: 25 Jan 2013
Posts: 21
Post Options Post Options   Quote Craggs David Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2019 at 6:07pm
Hmm - doesn't appear to be the event.

When it happens the markers seem to be different. 


If you see the two markers are slightly different. Click on the left one and it disappears.

They have both been added using the same code.
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2049
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 09 Sep 2019 at 8:39am
Hi,

I have not been able to reproduce these issues.
Can you please provide a ready to run sample project by email (mailto:help@tmssoftware.com) that demonstrates the issue so I can further investigate this?
Back to Top
Craggs David View Drop Down
New Member
New Member
Avatar

Joined: 25 Jan 2013
Posts: 21
Post Options Post Options   Quote Craggs David Quote  Post ReplyReply Direct Link To This Post Posted: 13 Sep 2019 at 2:26pm
I deleted the component and re added it to the form.

After re linking the events, the problem no longer happens.

Strange
Back to Top
Craggs David View Drop Down
New Member
New Member
Avatar

Joined: 25 Jan 2013
Posts: 21
Post Options Post Options   Quote Craggs David Quote  Post ReplyReply Direct Link To This Post Posted: 13 Sep 2019 at 2:38pm
What about the original question regarding ID?

Dave
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2049
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: Yesterday at 9:20am
Can you please make sure the markers are removed from both the Markers collection and the map?
For example, when using the ClearMapMarkers call, the markers are only removed from the map but not from the Markers collection.

If the problem persists, please provide a ready to run sample project that demonstrates the issue by email (mailto:help@tmssoftware.com).
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down